News Anuman

Application compatibility with iOS11 (Anuman - Bordas)
We regret to announce that some of our applications do not support the latest Apple iOS11.0.3 or higher update.  For the moment, no update is planned to...
Mon, 18 Dec, 2017 at 5:31 PM